iPad, iPhone, iPod touch, Jailbreak News

Jailbreak for non A5 Devices on iOS 5.1 – Tethered

The Dev-Team figured out a jailbreak for iOS 5.1. This only applies to non-A5 devices. So if you have an iPad 2 or an iPhone 4S, continue waiting as the security measure set in place on those devices are much more complicated than that of an A4. If you have a pre-A5 device and would like to jailbreak you can do so by clicking on this link. There you will find the files necessary to jailbreak your A4 on iOS 5.1.

A couple things to keep in mind as listed on the Dev-Team Blog are,

  • This is a *tethered* 5.1 jailbreak for non-A5 devices.  You’ll need to use redsn0w to “Just Boot” your device every time it power cycles, otherwise jailbreak apps won’t work (neither will Safari).
  • If you use ultrasn0w for your carrier unlock, be sure to use a custom IPSW to get to 5.1 first!  Don’t ever restore to a stock Apple IPSW!  Use redsn0w’s “Custom IPSW” button to create a NO_BB_* version of the 5.1 IPSW and restore to that instead of the stock one.  (That option is available only to 3GS and iPhone4-GSM owners.)  ultrasn0w itself will be updated for 5.1 in the next few days (same baseband support, not 5.1’s baseband).
  • If you’re lucky enough to have an old-bootrom 3GS, this jailbreak is actually untethered (redsn0w will figure that part out automatically).
  • While we were at it, we added @pod2g’s steaks4uce exploit to support MC models of the iPod touch 2G (whose last firmware was 4.2.1).  So now redsn0w will auto-detect and jailbreak both MB and MC versions of that older device.
  • iBooks won’t work until a future update of redsn0w

So basically, if you can handle the restrictions of a tethered jailbreak then your good to go!

Are you going to update just so you can jailbreak again?

Share this Story

Related Posts

Join Our Mailing List

Email Format

Free iTunes Gift Cards!

Find us on Google Plus